Adam

Forum Replies Created

Viewing 15 posts - 16 through 30 (of 65 total)
  • Author
    Posts
  • in reply to: Canon G7X – GUID Issue #739
    Adam
    Participant

    I’m still around, just been busy with some other projects 🙂

    Can you post your wireshark captures of both Canon App -> Camera and Airnef -> Camera sessions (Airnef using your patched GUI).

    • This reply was modified 5 years, 2 months ago by Adam.
    in reply to: Nikon D5600 AirNef not working #714
    Adam
    Participant

    Hi,

    Are you using an Android phone? If so, is Snapbridge turning your phone’s WiFi on even if you had the phone’s WiFi disabled prior to telling Snapbridge to enable WiFi on your D5600? When I tested this with the original version of Snapbridge the app wouldn’t attempt to turn switch the phone’s WiFi network to the camera’s as long as I had WiFi disabled on the phone prior to directing Snapbridge to enable WiFi on the camera.

    Adam

    in reply to: Downloading Single specific file #713
    Adam
    Participant

    Hi,

    There’s no way to filter downloads by filename. But you can filter downloads by a date range and time range, so a clunky workaround you can use is to take the date+time of the file you want to download and use that value for the –startdate and –enddate parameters. For example, if the file you want was taken on 3/20/2017 at 8:01:05PM, you can use:

    –startdate 03/20/17 20:01:05 –enddate 03/20/17 20:01:05

    Adam

    in reply to: Canon EOS M5: connection refused #686
    Adam
    Participant

    Hi Kai,

    Thanks for going through the effort to try it. Glad it worked!

    in reply to: Canon EOS M5: connection refused #683
    Adam
    Participant

    Thanks Kai. Based on the log the camera is either rejecting/not-supporting the ‘Send probe request’ or is the point at which further PTP-IP communication fails, with that being the first command. One thing we can try is to disable that specific command and see if Airnef gets further. If your comfortable with a bit of tech the easiest way to do this would be to download the source and modify it, then run it under the Python runtime which is also available online for free.

    Here’s the link to the Airnef 1.1 source and the Python runtime (I would use the latest 2.7.x release):
    Airnef v1.1 source
    Python download

    To disable the ‘Send Probe’ command, just insert a # in column 1 of line 1137 of the source you downloaded, so that it looks like this:

    # mtpwifi.sendProbeRequest(g.socketEvents)

    You can then run Airnef from your downloaded+modified source copy by either double clicking on the airnef.pyw file or by entering a command window and typing ‘python airnef.pyw’

    • This reply was modified 5 years, 7 months ago by Adam.
    in reply to: Canon EOS M5: connection refused #681
    Adam
    Participant

    Hi Kai,

    It sounds like the camera is in one of the image transfer modes that isn’t specific to sending images to the computer, which means it’ll refuse the PTP-IP connection that Airnef is attempting to establish. I looked through the M5 manual and it has a ton of connection options and it’s not clear exactly which you need to use – I don’t have my 6D anymore so I don’t recall which I used on that body with Airnef. Can you try the various methods and see if any work and report back? Thanks!

    Adam
    Participant

    I really wish I had one of these Canon’s so I could debug this. It’s likely just a minor protocol difference that wouldn’t take long to fix. In the meantime have you guys used Canon’s EOS Utility software to wirelessly transfer images? It works rather well.

    • This reply was modified 5 years, 8 months ago by Adam.
    • This reply was modified 5 years, 8 months ago by Adam.
    Adam
    Participant

    Thanks for the update Joe. With the cache bypassed, Airnef is now getting the same error when it tries to query the metadata for that same object (handle 0x90000000, probably the object associated with the DCIM directory on the card) but the transfer is failing, as if the camera doesn’t support retrieving object info for it, which shouldn’t be the case. Unfortunately this would be hard to debug remotely. Can you try formatting the card in the camera in the off chance this is a subdirectory that the camera itself didn’t create (perhaps created from another camera or your desktop).

    • This reply was modified 5 years, 8 months ago by Adam.
    Adam
    Participant

    Thanks xaphod. Right now Airnef doesn’t use those Canon-specific notification commands but I’ll keep the information you provided in mind in case that ever changese.

    Adam
    Participant

    Joe,

    The error is occurring when Airnef is attempting to validate its cache of objects (metadata for image files) received from a previous invocation. The cache is a performance-enhancing feature that allows Airnef to avoid downloading metadata for files it already downloaded from a previous invocation. I’m not sure why the operation to validate the cache is failing but try adding –mtpobjcache=disabled (that’s two dashes before mptobjcache – WordPress is collapsing my comment to one dash for some reason) to the command line. You can do this in airnef in the ‘Additional args’ edit field and see if gets past the problem.

    Adam

    • This reply was modified 5 years, 8 months ago by Adam.
    • This reply was modified 5 years, 8 months ago by Adam.
    • This reply was modified 5 years, 8 months ago by Adam.
    Adam
    Participant

    I launch airnefcmd in an xterm process. Perhaps xterm isn’t installed on your system or not in the path? Here’s the python source line that launches for Linux:

    process = subprocess.Popen([‘xterm’, ‘+hold’, ‘-e’, os.path.join(g.appDir, ‘airnefcmd’)] + argList)

    Adam
    Participant

    Based on the error, airnefcmd is not being found when airnef launches it (airnef is the front-end GUI – it launches airnefcmd to do the actual work). airnef uses the directory it was launched from to find/specify airnefcmd, so as long as both are in the same directory it should work.

    Adam
    Participant

    Also, can you retry reformatting the SD card in the camera? The new firmware may have changed an element of the directory structure and so if the card was formatted with the previous firmware it may have an object that the new firmware is not expecting or not handling correctly for the MTP interface.

    Adam
    Participant

    Thats for posting the log. Based on the log the camera is not allowing airnef to retrieve information about the second MTP directory/file object that the camera is reporting in its list of objects – it’s either a bug in Nikon’s new firmware or they’ve changed the implementation/definition by adding objects whose info can’t be retrieved. Unfortunately I don’t have a AW 130 to try to troubleshoot it.

    in reply to: Airnef connection problem #637
    Adam
    Participant

    Hi,

    Configure your camera and computer so that its WiFi network is on a different subnet than your wired connection. By default most home networks use a common subnet like 192.168.1.x, which is also the default subnet for consumer WiFi devices like your camera. Since they use the same subnet they’ll conflict when you try to use both at the same time.

Viewing 15 posts - 16 through 30 (of 65 total)