Nikon P900 issue

Home Forums Nikon P900 issue

Tagged: 

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #519
    joem65
    Participant

    Are not able to download pictures/movies from my Coolpix P900 camera.

    When the download should start, I get this message:
    ——————-
    airnef v1.00 – Wireless transfer of images/movies for Nikon cameras [GPL v3]
    Copyright (c) TestCams.com, App Launch Time: Fri Sep 25 09:47:55 2015

    Connection established to 192.168.0.10:15740
    Camera Command Failed: MTP_OP_OpenSession, Error: MTP_RESP_InvalidParameter
    —————
    Does not matter if I select images in the camera or on your computer.

    what could be the problem?

    / Johan

    #520
    Adam
    Participant

    Thanks. This might be the same issue as the J5. I’m still trying to get a hold of a J5 – it should only take a day or two to resolve once I have one. To help me see if it’s the same issue can you set the logging level to ‘debug’ and retry the download and post the resulting log here? Thanks!

    #525
    joem65
    Participant

    Of course. Here it is:
    ———————
    airnef v1.00 – Wireless transfer of images/movies for Nikon cameras [GPL v3]
    Copyright (c) TestCams.com, App Launch Time: Fri Sep 25 23:01:10 2015

    Orig cmd line: [‘C:\\PROGRA~1\\airnef\\airnefcmd.exe’, ‘–outputdir’, ‘C:\\Program Files\\airnef’, ‘–ifexists’, ‘uniquename’, ‘–ipaddress’, ‘192.168.0.10’, ‘–logginglevel’, ‘debug’, ‘–cameratransferlist’, ‘exitifnotavail’]
    Processed cmd line: {‘connecttimeout’: 10, ‘printstackframes’: ‘no’, ‘camerafolderinoutputdir’: ‘no’, ‘mtpobjcache_maxagemins’: 0, ‘outputdir’: ‘C:\\Program Files\\airnef’, ‘extlist’: [‘<ALL>’], ‘slot’: ‘firstfound’, ‘startdate’: None, ‘downloadhistory’: ‘skipfiles’, ‘maxgetobjbuffersizekb’: 32768, ‘cameratransferlist’: ‘exitifnotavail’, ‘socketreadwritetimeout’: 5, ‘retrydelaysecs’: 5, ‘ifexists’: ‘uniquename’, ‘logginglevel’: ‘debug’, ‘retrycount’: 2147483647, ‘excludefolders’: None, ‘ipaddress’: ‘192.168.0.10’, ‘maxgetobjtransfersizekb’: 1024, ‘onlyfolders’: None, ‘enddate’: None, ‘mtpobjcache’: ‘enabled’, ‘action’: ‘getfiles’, ‘transferorder’: ‘oldestfirst’}
    openConnection(): Attempting connection to 192.168.0.10:15740
    Connection established to 192.168.0.10:15740
    sendHostIntroduction(): Sending introduction
    0000: 01 00 00 00 00 11 22 33 – 44 55 66 77 88 99 aa bb ……”3 – DUfw….
    0010: cc dd ee ff 61 00 69 00 – 72 00 6e 00 65 00 66 00 ….a.i. – r.n.e.f.
    0020: 00 00 01 00 00 00 ……
    sendHostIntroduction() response:
    0000: 02 00 00 00 00 00 00 00 – 30 30 31 31 32 32 33 33 …….. – 00112233
    0010: 34 34 35 35 36 36 37 37 – 00 00 00 00 01 00 44556677 – ……
    Session ID = 0x00000000
    openConnection(): Attempting connection to 192.168.0.10:15740
    sendInitEvents(): Sending init_events
    0000: 03 00 00 00 00 00 00 00 – …….. –
    sendInitEvents() response:
    0000: 04 00 00 00 ….
    >> Delaying for 1 second to avoid open session issue
    execMtpOp: MTP_OP_OpenSession – CmdReq payload:
    0000: 06 00 00 00 01 00 00 00 – 02 10 01 00 00 00 00 00 …….. – ……..
    0010: 00 00 ..
    execMtpOp: MTP_OP_OpenSession – CmdResponse payload (resp=”MTP_RESP_InvalidParameter”):
    0000: 07 00 00 00 1d 20 01 00 – 00 00 ….. .. – ..
    Camera Command Failed: MTP_OP_OpenSession, Error: MTP_RESP_InvalidParameter
    ——-

    I think you’ve done an awesome program. Good luck!!

    / Johan

    #526
    Adam
    Participant

    Thanks for posting the debug log. It appears to be the same issue with the J5. I’m still trying to get a hold of one…

    #539
    stutum
    Participant

    Any news ab. the Coolpix P900 ? Still cannot do the wifi to Mac. . . .

    #540
    Adam
    Participant

    The J5 and P900 issue has been resolved. The fix will be included in the v1.1 release, which is expected in about a week or so.

    #542
    stutum
    Participant

    🙂 I like !

    #554
    stutum
    Participant

    Tested and found EXCELLENT 😉 Thank you ! (Nikon P900)

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.