GUID problem with Canon and Linux

Home Forums GUID problem with Canon and Linux

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #576
    eater
    Participant

    I have a Canon S110 that I’m trying to connect via Airnef 1.1 on Linux, but I am getting the below error.

    I’ve reset all the camera’s wireless settings a few times, and I’m on a newly created wi-fi network. What can I do to get rid of the error?

    Connection established to 192.168.50.10:15740                                 
    
    The camera is rejecting the unique identifier (GUID) that airnef is
    presenting. Some cameras including most Canon's associate a given Wifi
    configuration to a particular remote application's GUID. If you have used a
    remote application other than airnef with this camera (or a different
    version of airnef) then you may need to re-create the WiFi configuration
    on the camera to allow it to be associated with airnef's GUID.
    #578
    Adam
    Participant

    Hmmm, my S120 works. The only time I’ve seen this error on Canon bodies is as the message describes – the camera thinks a client other than Airnef is registered for the WiFi config. Does the camera work with Canon’s iOS app? (CameraWindow or CameraConnect)

    #581
    eater
    Participant

    Yes, I’ve connected with CameraWindow on Android and on OS X with no problem.

    I’m doing Camera Settings > Wireless LAN Settings > Reset Settings and when I do that, it does forget all the devices and networks it knew about — is there another way I can clear out the GUID though?

    #584
    lm.org
    Participant

    I have same problem with S110. Tried both versions, reset whole camera settings… When spoofing GUID tcpdumped from CameraWindow on OS X and using this GUID as parameter (converted to big endian) for airnef on same host it works for few seconds – (airnef show camera info) but listfiles failed.
    With Canon 70D works airnef correct.

    Anyway, good job – thank You πŸ™‚

    #589
    mainedog
    Participant

    I have a new SX710HS Canon PowerShot.. It works with Airnef when the host computer is connected to the router via ethernet cable, but not when the host is connected via wifi. It finds and connects to the camera, but the camera rejects the GUID.

    #608
    Riddy
    Participant

    I recently acquired a new Canon Powershot G9X. I had the GUID rejection problem both using home wifi and using the camera as an access point. I could connect to the camera but could not download images. I was able to get it working by using the “Print from Wi-Fi printer” option in the wi-fi menu on the camera. The “Connect to Smartphone” and “Connect to computer” options resulted in the GUID error. At the Airnef end the camera’s IP address was 192.168.0.1 for the direct connect method, for home wi-fi the router will set the camera’s IP. The Airnef “Select on Computer” download option works fine. I hope this is helpful.

    #617
    Torsten
    Participant

    I get the same GUID reject error message with my Canon Powershot G16. “Auto” option for IP address doesn’t work at all.

    The Canon Image Gateway to the internet server worked until I resetted the G16’s WLAN. But who wants to upload his photos to somewhere just to download them after?

    #619
    skyking
    Participant

    Same GUID error message here with Canon G7X. Reset WiFi on Camera. Laptop hard wired to router. Camera is 192.168.1.21 auto assigned and reserved on router and I tried all WiFi profiles – Printer, Mobile, Computer and they all result in GUID message. Was really hoping not to have to plug in USB to move pics over. Anyone find a solution to this? Seems to be Canon specific.

    #620
    skyking
    Participant

    Update: Tried airnef v1.0 and error is now: badhostsomething expected x02 got x05 which I guess in v1.1 means bad GUID?

    Looks like Canon G7X is not going to accept the the GUID from airnef at all.

    #621
    skyking
    Participant

    Adam, if you check here for folks having issues, I have tried everything with the gui and camera (wifi resets) with no luck. I have now tried running command line and changing GUID there:

    ./airnefcmd –ipaddress 192.168.1.21 –action listfiles –initcmdreq_guid 5c:26:0a:65:9a:54

    Same result ‘camera rejecting guid’ error. I’d be happy to try out different things to find a solution if you could give me some ideas and guidance. Thanks.

    #622
    AKADAP
    Participant

    Add me as another G16 user that is unable to use airnef because of the “The camera is rejecting the unique identifier (GUID) that airnef is presenting.” error.
    Yes I have reset the networking stuff on the camera, and it does not help.

    Auto settings did not work at all.

    I’m using this with a desktop computer running Linux Mint hard wired to a LAN with a WIFI router acting as an access point.

    #626
    Terry
    Participant

    I have the same problem with a Canon IXUS. β€œThe camera is rejecting the unique identifier (GUID) that airnef is presenting.” error. This is with Ubuntu via a WIFI router.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.