Cannot connect to a camera: OSError: [Errno 2] No such file or directory

Home Forums Cannot connect to a camera: OSError: [Errno 2] No such file or directory

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #642

    Set up airnef under Gentoo linux by untaring it in ~
    Launching it as ./airnef/airnef/airnef seems okay but when I press big button with “wireless” pic I got the following in the terminal window:

    Launching airnefcmd with args: –outputdir “/home/kanyck/Pictures” –ifexists uniquename –ipaddress –realtimedownload disabled –logginglevel normal –cameratransferlist exitifnotavail
    Exception in Tkinter callback
    Traceback (most recent call last):
    File “/usr/lib/python2.7/lib-tk/”, line 1535, in __call__
    File “<string>”, line 809, in <lambda>
    File “<string>”, line 859, in wizard_1_0_ButtonClick
    File “<string>”, line 255, in launchAirnefcmd
    File “/usr/lib/python2.7/”, line 710, in __init__
    errread, errwrite)
    File “/usr/lib/python2.7/”, line 1335, in _execute_child
    raise child_exception
    OSError: [Errno 2] No such file or directory

    What can be the reason?


    Based on the error, airnefcmd is not being found when airnef launches it (airnef is the front-end GUI – it launches airnefcmd to do the actual work). airnef uses the directory it was launched from to find/specify airnefcmd, so as long as both are in the same directory it should work.


    That’s very strange. airnefcmd is in the same directory as airnef, namely ~/airnef/airnef. I did not touch anything, just unpacked the tarball into my home directory. I may issue airnefcmd by hand and it works. But I keep getting the same error whatever I try when I use gui. I cd-ed into airnef/airnef an tried to launch the front-end from there. I added ~/airnef/airnef into the PATH environment variable. Now I can issue both airnef and airnefcmd just as any other command — without any dir prefixes but I still get the same error.
    which airnefcmd founds in and returns the right path.
    How do you launch it?


    I launch airnefcmd in an xterm process. Perhaps xterm isn’t installed on your system or not in the path? Here’s the python source line that launches for Linux:

    process = subprocess.Popen([‘xterm’, ‘+hold’, ‘-e’, os.path.join(g.appDir, ‘airnefcmd’)] + argList)


    Sure, I’ve no xterm in the system — that’s the reason — been using lilyterm for a long time. Could you parse $TERM env variable instead? That will be more correct and compliant with the “unix way”. Thanks!

    UPDATE: I checked it out and found that $TERM does different thing, namely sets the term capabilities. I did not found the way how to generalize the term emulator invocation (and suppose there’s no way to do it because there are about two dozens of TE in linux and they use different command-line sintax when invoked so to simply substitute a program name won’t work). So I may try to symlink my TE to xterm (hoping that sintax will match) or just install xterm purposely for airnef. Thanx again!

    • This reply was modified 5 years, 9 months ago by kanyck.

    The symlink trick has worked. So I can download pics now. Maybe you should mention it in the docs. Could not manage to invoke geeqie via downloadexec yet but it’s another story. Thanx again!

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.