Airnef error with Canon 1300D -MTP_OP_GetObjectInfo: Socket error, partial data

Home Forums Airnef error with Canon 1300D -MTP_OP_GetObjectInfo: Socket error, partial data

This topic contains 12 replies, has 5 voices, and was last updated by  wahlis 6 months, 4 weeks ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #659

    Joe
    Participant

    Hi
    Can’t get Canon EOS 1300D to work with Airnef. Currently I’m trying to connect the laptop to Camera wifi hotspot. I get the following error in airnef log and then in Camera, LCD screen goes back to the default screen ( the one which you get right after powering on the camera). Any suggestions will be really appreciated. Thanks.

    Validating MTP obj cache directory object “DCIM” on handle 0x90000000

    execMtpOp: MTP_OP_GetObjectInfo – CmdReq payload:

    0000: 06 00 00 00 01 00 00 00 – 08 10 07 00 00 00 00 00 …….. – ……..

    0010: 00 90 ..

    MTP_OP_GetObjectInfo: Socket error, partial data received – 0x0 of 0x0 bytes for specific payload, 0x0 of 0x0 of total data bytes expected. Error: timed out

    Regards
    Joe

    #660

    xaphod
    Participant

    To the airnef author: there were two changes in the Canon 750D, 760D, and 80D cameras that i’m aware of for PTP / MTP:
    – Instead of PTP_EC_CANON_EOS_ObjectAddedEx (event code indicating an object was added) being 0xC181, they use 0xC1A7 instead
    – live-view frames use type 0x0B (instead of 0x01) to indicate JPG type

    hope this helps

    #661

    Adam
    Participant

    Joe,

    The error is occurring when Airnef is attempting to validate its cache of objects (metadata for image files) received from a previous invocation. The cache is a performance-enhancing feature that allows Airnef to avoid downloading metadata for files it already downloaded from a previous invocation. I’m not sure why the operation to validate the cache is failing but try adding –mtpobjcache=disabled (that’s two dashes before mptobjcache – WordPress is collapsing my comment to one dash for some reason) to the command line. You can do this in airnef in the ‘Additional args’ edit field and see if gets past the problem.

    Adam

    • This reply was modified 7 months, 3 weeks ago by  Adam.
    • This reply was modified 7 months, 3 weeks ago by  Adam.
    • This reply was modified 7 months, 3 weeks ago by  Adam.
    #662

    Adam
    Participant

    Thanks xaphod. Right now Airnef doesn’t use those Canon-specific notification commands but I’ll keep the information you provided in mind in case that ever changese.

    #666

    Joe
    Participant

    Hi Adam, xaphod,

    Tried using “–mtpobjcache=disabled” as Adam suggested. Still no joy. Getting the following error

    Regards
    Joe

    execMtpOp: MTP_OP_OpenSession – CmdReq payload:
    0000: 06 00 00 00 01 00 00 00 – 02 10 09 00 00 00 01 00 …….. – ……..
    0010: 00 00 ..
    execMtpOp: MTP_OP_OpenSession – CmdResponse payload (resp=”MTP_RESP_Ok”):
    0000: 07 00 00 00 01 20 09 00 – 00 00 ….. .. – ..
    execMtpOp: MTP_OP_Canon_SetDevicePropValue – CmdReq payload:
    0000: 06 00 00 00 02 00 00 00 – 10 91 0a 00 00 00 …….. – ……
    execMtpOp: Sending MTP_TCPIP_PAYLOAD_ID_DataStart
    0000: 09 00 00 00 0a 00 00 00 – 0c 00 00 00 00 00 00 00 …….. – ……..
    execMtpOp: Sending MTP_TCPIP_PAYLOAD_ID_DataPayloadLast:
    0000: 0c 00 00 00 0a 00 00 00 – 0c 00 00 00 7c d1 00 00 …….. – ….|…
    0010: c0 30 3d 58 .0=X
    execMtpOp: MTP_OP_Canon_SetDevicePropValue – CmdResponse payload (resp=”MTP_RESP_DeviceBusy”):
    0000: 07 00 00 00 19 20 0a 00 – 00 00 ….. .. – ..
    Failed setting camera’s date/time to 11/29/16 01:09:44 PM
    execMtpOp: MTP_OP_GetStorageIDs – CmdReq payload:
    0000: 06 00 00 00 01 00 00 00 – 04 10 0b 00 00 00 …….. – ……
    execMtpOp: MTP_OP_GetStorageIDs – DataStart payload [expected data bytes is 0x8]
    0000: 09 00 00 00 0b 00 00 00 – 08 00 00 00 00 00 00 00 …….. – ……..
    execMtpOp: MTP_OP_GetStorageIDs – Data payload [ID c] (0x00000010 bytes):
    0000: 0c 00 00 00 0b 00 00 00 – 01 00 00 00 01 00 02 00 …….. – ……..
    execMtpOp: MTP_OP_GetStorageIDs – CmdResponse payload (resp=”MTP_RESP_Ok”):
    0000: 07 00 00 00 01 20 0b 00 – 00 00 ….. .. – ..
    All Storage IDs:
    storageId[0] = 0x00020001
    storageId to be used for this invocation: 00020001 [cardsPresentBitmap=0x0001]
    execMtpOp: MTP_OP_GetStorageInfo – CmdReq payload:
    0000: 06 00 00 00 01 00 00 00 – 05 10 0c 00 00 00 01 00 …….. – ……..
    0010: 02 00 ..
    execMtpOp: MTP_OP_GetStorageInfo – DataStart payload [expected data bytes is 0x24]
    0000: 09 00 00 00 0c 00 00 00 – 24 00 00 00 00 00 00 00 …….. – $…….
    execMtpOp: MTP_OP_GetStorageInfo – Data payload [ID c] (0x0000002c bytes):
    0000: 0c 00 00 00 0c 00 00 00 – 04 00 03 00 00 00 00 00 …….. – ……..
    0010: 70 ba 03 00 00 00 00 00 – 0a b9 03 00 00 00 ff ff p……. – ……..
    0020: ff ff 03 53 00 44 00 00 – 00 00 00 00 …S.D.. – ….
    execMtpOp: MTP_OP_GetStorageInfo – CmdResponse payload (resp=”MTP_RESP_Ok”):
    0000: 07 00 00 00 01 20 0c 00 – 00 00 ….. .. – ..
    MtpStorageInfoTuple(storageType=4, fileSystemType=3, accessCapability=0, maxCapacityBytes=16012804096L, freeSpaceBytes=15989342208L, freeSpaceInImages=4294967295L, storageDescription=3, volumeLabel=u’\u4400′)
    execMtpOp: MTP_OP_GetObjectHandles – CmdReq payload:
    0000: 06 00 00 00 01 00 00 00 – 07 10 0d 00 00 00 01 00 …….. – ……..
    0010: 02 00 00 00 00 00 00 00 – 00 00 …….. – ..
    execMtpOp: MTP_OP_GetObjectHandles – DataStart payload [expected data bytes is 0x20]
    0000: 09 00 00 00 0d 00 00 00 – 20 00 00 00 00 00 00 00 …….. – …….
    execMtpOp: MTP_OP_GetObjectHandles – Data payload [ID c] (0x00000028 bytes):
    0000: 0c 00 00 00 0d 00 00 00 – 07 00 00 00 00 00 00 90 …….. – ……..
    0010: 00 00 90 91 c2 2d 90 91 – d2 2d 90 91 e2 2d 90 91 …..-.. – .-…-..
    0020: f2 2d 90 91 00 00 08 a0 – .-…… –
    execMtpOp: MTP_OP_GetObjectHandles – CmdResponse payload (resp=”MTP_RESP_Ok”):
    0000: 07 00 00 00 01 20 0d 00 – 00 00 ….. .. – ..
    All MTP object handles (count=7):
    0000: 90000000 91900000 – 91902dc2 91902dd2
    0010: 91902de2 91902df2 – a0080000
    execMtpOp: MTP_OP_GetObjectInfo – CmdReq payload:
    0000: 06 00 00 00 01 00 00 00 – 08 10 0e 00 00 00 00 00 …….. – ……..
    0010: 00 90 ..
    MTP_OP_GetObjectInfo: Socket error, partial data received – 0x0 of 0x0 bytes for specific payload, 0x0 of 0x0 of total data bytes expected. Error: timed out

    openConnection(): Attempting connection to 192.168.1.2:15740

    >> Terminated by user keypress – cleaning up, please wait… <<

    #667

    Adam
    Participant

    Thanks for the update Joe. With the cache bypassed, Airnef is now getting the same error when it tries to query the metadata for that same object (handle 0x90000000, probably the object associated with the DCIM directory on the card) but the transfer is failing, as if the camera doesn’t support retrieving object info for it, which shouldn’t be the case. Unfortunately this would be hard to debug remotely. Can you try formatting the card in the camera in the off chance this is a subdirectory that the camera itself didn’t create (perhaps created from another camera or your desktop).

    • This reply was modified 7 months, 3 weeks ago by  Adam.
    #669

    Joe
    Participant

    Hi Adam,
    Thanks for the suggestion. The SD card I was using was a camera formatted one. It only had 7 images which I clicked just before trying to initiate the transfer using airnef. Thanks.

    Regards
    Joe

    #671

    Luigy
    Participant

    Hi guys,
    I’m having exactly the same issue with my Canon 1300D. Same thing in the log.
    I’m just wondering if it’s possible that Canon made the storage for this camera somehow read-protected. You know that this is very cheap camera and Canon made it incompatible with official EOS Utility for a reason.
    I would love to be able to transfer the photos over wifi to my PC though. Any help would be very appreciated.

    #674

    Joe
    Participant

    Luigy, so looks like apparently all the EOS 1300D cameras have this issue. Seems cannon had product differentiation in mind when they decided to disable connectivity to PC when the cam had a built in wifi. But what I don’t understand is, if the camera is able to transfer photos to a smart phone, why could it not transfer to airnef which just simulates a smart phone. Its a shame, a camera having wifi not able to share photos with a PC. 1300D is a cheap entry level DSLR, but does that offer an excuse for canon to disable a wifi connectivity to PC. wifi compatibility was one among the compelling reason why I bought this camera. Who would ever think canon would intentionally cripple this camera. I would be delighted to see any work around (I’m sure there should be one).

    Regards
    Joe

    #675

    Luigy
    Participant

    My guess is that the Canon app is using some different (maybe encrypted) protocol. That’s what I would do if I were in position of Canon.
    Maybe there’s a way around it but it will take some time…

    #676

    Adam
    Participant

    I really wish I had one of these Canon’s so I could debug this. It’s likely just a minor protocol difference that wouldn’t take long to fix. In the meantime have you guys used Canon’s EOS Utility software to wirelessly transfer images? It works rather well.

    • This reply was modified 7 months, 1 week ago by  Adam.
    • This reply was modified 7 months, 1 week ago by  Adam.
    #679

    Joe
    Participant

    Adam, with the Canon’s EOS Utility software the camera’s MAC address is not listed. Further, since the camera does not have a laptop or PC to transfer files too, I believe, the Canon has disabled this in EOS Utility atleast for the 1300D model. This was the primary reason why I turned to airnef.

    Thanks
    Joe

    #687

    wahlis
    Participant

    Hi,

    I have the same issue, MTP_OP_GetObjectInfo: Socket error, partial data received - 0x0 of 0x0 bytes for specific payload, 0x0 of 0x0 of total data bytes expected. Error: timed out

    Any suggestions on how to continue? Anything I can do to help debug the issue?

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.