Airnef connection problem

Home Forums Airnef connection problem

This topic contains 2 replies, has 2 voices, and was last updated by  Adam 5 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #630

    djboshh
    Participant

    Hi, thanks for your great Airnef program. I’ve managed to use it to connect my Canon 750d to my pc over Wi-fi (ad hoc). It’s a little cumbersome as i keep having to disconnect the PC’s wired ethernet connection (via network connections) and instead connect to the camera’s own Wi-fi network over WiFi. I’m trying to use infrastructure mode instead to negate having to do all that.
    However, it’s almost working but I get the following error:

    In infrastructure mode, camera says “connect to this smartphone: airnef”. So the camera can see the Airnef app on the PC. However, airnef then says
    -Found camera at IP address 192.168.0.5
    -Connection established to 192.168.0.5:15740
    -Camera is accepting connections but failing to negotiate a session. You may
    need to turn the camera’s WiFi off and of or cycle the camera’s power to
    recover. You can leave airnefcmd running while doing this.

    I’ve tried Airnef’s suggestion of turning off the camera’s WiFi and turning off the camera and on again but the same error occurs.

    Any ideas?

    #634

    djboshh
    Participant

    Edit: Even though I don’t adequately understand how wireless networks and settings work, I had the idea of turning off my mobile phone and then trying infrastructure mode in the camera to connect to Airnef. It’s either just a coincidence or the solution but Airnef then worked via infrastructure mode. I do have Canon wireless software on my mobile phone. Could that of been conflicting?

    #637

    Adam
    Participant

    Hi,

    Configure your camera and computer so that its WiFi network is on a different subnet than your wired connection. By default most home networks use a common subnet like 192.168.1.x, which is also the default subnet for consumer WiFi devices like your camera. Since they use the same subnet they’ll conflict when you try to use both at the same time.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.